Bądź: Wyszukaj na stronie z użyciem Google
reklama:

środa, 21 maja 2008

Błąd kernela

Autor: , 15:00, środa, 21 maja 2008


Ostatnimi czasy niespodziewanie wykryto krytyczny błąd w kodzie jądra systemowego. Błąd ten umożliwiał nadawanie zwykłemu użytkownikowi praw
administratora, a zlokalizowany był w kodzie funkcji vmsplice(). Błąd ten został wykryty w kodzie jądra w wersji 2.6.17 i późniejszych.



Wersje jądra pozbawione błędu to 2.6.24.2, 2.6.23.16 oraz 2.6.22.18. Jednocześnie w kodzie jądra w wersji 2.6.23 wykryto inny błąd o analogicznym działaniu, jak opisany powyżej. Wersje jądra pozbawione drugiego błędu to 2.6.23.15 oraz
2.6.24.1. Z powyższych względów zaleca się aktualizację jądra do wyżej wspomnianych wersji:

# emerge =gentoo-sources-2.6.23-r8

lub

# emerge =gentoo-sources-2.6.24-r2

Pierwsze polecenie instaluje najnowszą bezpieczną stabilną wersję jądra, natomiast drugie – niestabilną.

info: Linux+ 5/2008

Tagi:

Komentarze 0 comments

Prześlij komentarz


Popularne posty

Etykiety