Bądź: Wyszukaj na stronie z użyciem Google
reklama:

czwartek, 13 sierpnia 2009

Ubuntuzilla - łatwiejsza instalacja aplikacji Mozilli

Autor: , 15:38, czwartek, 13 sierpnia 2009


Nie po to używa się Linuksa aby korzystać ze starszych wersji programów lecz by te nowsze działały jeszcze szybciej i stabilniej. Ubuntuzilla to skrypt stworzony w Pythonie, którym opiekuje się UbuntuForums.org, pozwalający na prostą instalację najnowszych wersji aplikacji dostarczanych przez Mozillę.

W ich skład wchodzą Firefox, SeaMonkey i Thunderbird - całość jak nazwa wskazuje działa jedynie pod Ubuntu.

Jakie korzyści daje Ubuntuzilla?

Po co instalować Firefoksa czy Thunderbirda za pomocą Ubuntuzilli skoro można je zwyczajnie wgrać ze standardowych repozytoriów? Korzyści jest całkiem sporo. Do najważniejszych należą między innymi automatyczne wyszukiwanie najnowszych wersji (często na długo zanim pojawią się w repozytoriach) a także wykonywanie automatycznej kopii przy instalacji czy chociażby możliwość wyboru wersji językowej.

Instalacja Ubuntuzilla

Na początek musimy zainstalować zależności, zatem wpisujemy w konsoli:
sudo apt-get install libstdc++5 libnotify-bin
Później wystarczy już tylko pobrać paczkę Deb do prostej instalacji z tej strony i wgrać podwójnym kliknięciem.

Instalacja aplikacji z Ubuntuzilla

Wgrywanie poszczególnych aplikacji również jest dość proste i sprowadza się do wydania jednego z trzech poleceń:
ubuntuzilla.py -a install -p firefox
ubuntuzilla.py -a install -p thunderbird
ubuntuzilla.py -a install -p seamonkey
W ten sposób można na przykład prosto wgrać najnowszego Firefoksa 3.5.2.

Usuwanie aplikacji z Ubuntuzilla

Wgrać to wgrać, ale czasem trudniej jest usunąć program, który niezbyt się sprawdził. Analogicznie do wcześniejszych poleceń, aby skasować program wydajemy jedno z trzech:
ubuntuzilla.py -a remove -p firefox
ubuntuzilla.py -a remove -p thunderbird
ubuntuzilla.py -a remove -p seamonkey

Aktualizowanie aplikacji z Ubuntuzilla

Domyślnie instalator Ubuntuzilla sam zajmuje się narzędziami do aktualizacji, może się jednak zdarzyć, że przy wgrywaniu nie wszystko poszło tak jak trzeba, bądź zwyczajnie nie wybrałeś takiej opcji. Można to szybko naprawić aktualizując instalator danej aplikacji:
ubuntuzilla.py -a installupdater -p firefox
ubuntuzilla.py -a installupdater -p thunderbird
ubuntuzilla.py -a installupdater -p seamonkey
Ja z Ubuntuzilli korzystam już dość długo i jestem bardzo zadowolony, szczególnie, że nie muszę pobierać żadnych innych poprawek, gdy chcę na przykład zaktualizować tylko przeglądarkę (normalnie jest z tym więcej zabawy).

źródło: linuxpoison.blogspot.com
Komentarze 26 comments
Łukasz pisze...

Właśnie skorzystałem i nareszcie mam najnowszego liska.

Anonimowy pisze...

Ja tam wolę ręcznie instalować

Paszczak pisze...

A jak wasze czcionki w najnowszym FF pod ubuntu? Bo u mnie jak zainstaluje liska za pomocą Ubuntuzilla to są tragiczne. Tzn dużo gorsze niż w "Shiretoko" np.

Anonimowy pisze...

@Paszczak Litrki chyba mam normalne...
Skrypt fajny szkoda ze nie moge znalezc nigdzie repo do niego bo pojawiaja sie dosc czesto aktualizacje

Michał pisze...

Super sprawa... nareszcie nowy firefox i działa prawie tak szybko jak na windzie. Dzięki Adrian!

Anonimowy pisze...

A mi nie mogę pobrać kluczy GPG i co mam w takim przypadku zrobić?

Adrian Nowak pisze...

Najwygodniej będzie skorzystać z tego wpisu.

Anonimowy pisze...

Czy ta wersja FF posiada w sobie Ubufoxa?

Adrian Nowak pisze...

Z tego co widzę u siebie to nie posiada.

Anonimowy pisze...

Co chwila mam coś w stylu:
gpg: UWAGA: niebezpieczne prawa własności do pliku konfiguracyjnego `/home/abakus/.gnupg/gpg.conf'
gpg: nieszczelne uprawnienia ustawień - wołanie zewnętrznych programów wyłączone
gpg: błąd z komunikacją serwera kluczy: błąd ogólny
gpg: odbiór z serwera kluczy nie powiódł się: błąd ogólny
gpg --keyserver keymaster.veridis.com --recv 0E3606D9 812347DD
Previous command has failed to complete successfully. Exiting.
Process returned code 2
Unable to retrieve Mozilla Software Releases Public key from keymaster.veridis.com . Trying again...

Anonimowy pisze...

Kurde lipa straszna bo zawiesza mi sie po tej aktualizaji jak biore na pelny ekran filmiki np, z youtube ;/

Adrian Nowak pisze...

Możesz przecież usunąć i skorzystać ze standardowej wersji.

Śmigło pisze...

@Anonimowy, to raczej nie wina Ubuntuzilli, tylko firefoksa, z tego co wiem, to bardzo wielu ludzi ma bledy w FF podczas robienia Fullscreena na YT

Anonimowy pisze...

Próbowałem wielu instalacji firefoxa 3.5 ale żadna nie przyniosła oczekwianego skutku. po instalacji przez ubuntuzille wszystko ruszyło bez mrugnięcia okiemrazem z wtyczkami które miałem zaisntalowane. NAPRAWDE SUPER PROGRAM;D:D:D:D:D

Piotr Matyska pisze...

Co do błędów YT to na forum jest rozwiązanie

Anonimowy pisze...

Co za beznadzieja... ubuntu to dystrybucja która potrzebuje zewnętrznego programu żeby móc zainstalować nowszą i bezpieczniejszą wersję Firefoxa! :o
Każde inne distro ma najnowszego FF w domyślnych repozytoriach.
Żenada, dlatego przesiadłem się na openSUSE ^^

dragonn pisze...

@Piotr Matyska
Możesz dać linka, bo u mnie strasznie muli na fullscreen-ie na YT.

Tomasz pisze...

No ale niestety nadal nie działa wersja PL, mam nadzieje że będzie chociaż stabilniej działał ten Shiretoko.

Piotr pisze...

wszystko działa perfekto tylko trzeba się trochę naczekać wolno się ściaga :D

przemo pisze...

Tomasz, jak to nie działa? przed instalacja wybierasz wersje PL. FF działa ładnie i stabilnie, przynajmniej u mnie ;)

Adrian Nowak pisze...

U mnie też jest po polsku.

Michał pisze...

Zrobiłem mały teścik i od razu po uruchomieniu na Ubuntu FF 3.5 zajmuje 40mB, na windzie 120:D

Anonimowy pisze...

zainstalowało mi ale nie ma flasha i javy, jakos flasha jeszcze zainstalowałem ale jak to zrobic z java, ubuntu mam 64 bitowe

martino pisze...

dzięęęki! miałem jakiegoś minifilda, po angielsku bez speed diala itd teraz dobrzedziałajacy ff 3.5.2 :)

Anonimowy pisze...

wielkie dzięki .......wszystko działa ....ff 3.5.2 :)

Anonimowy pisze...

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Pakiet libstdc++5 nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.
E: Pakiet libstdc++5 nie ma kandydata do instalacji

lipa :(

Prześlij komentarz


Popularne posty

Etykiety